Bug #57008

New Installation: Could not acquire lock for ClassLoader

Added by Ernesto Baschny over 5 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Install Tool
Target version:
Start date:
2014-03-17
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

With the Class Loader Locking patch applied (see #55099) when installing a fresh new TYPO3 installation (no typo3temp directory present), I get:

( ! ) Fatal error: Uncaught exception 'RuntimeException' with message 'Could not acquire lock for ClassLoader cache creation.' in /www/sites/typo3-62/html/typo3_src/typo3/sysext/core/Classes/Core/ClassLoader.php on line 704
( ! ) RuntimeException: Could not acquire lock for ClassLoader cache creation. in /www/sites/typo3-62/html/typo3_src/typo3/sysext/core/Classes/Core/ClassLoader.php on line 704

This should be handled somehow.


Related issues

Related to TYPO3 Core - Bug #55099: PHP Warnings after clearing configuration cache in BE Closed 2014-01-17
Related to TYPO3 Core - Bug #57463: Upgrading 6.2: PHP Fatal error: Could not acquire lock for ClassLoader cache creation. Closed 2014-03-31
Duplicated by TYPO3 Core - Bug #57038: Cannot install 6.2 beta7 anymore from GIT Closed 2014-03-18

Associated revisions

Revision d2be4573 (diff)
Added by Alexander Opitz over 5 years ago

[BUGFIX] Exception in Locker if typo3temp does not exist

Follow-up to 2268f64c18b607ba39d06b1580afb0ccd786d6b1

If typo3temp does not exist, the Locker should throw an exception.
The ClassLoader needs to catch this exception and acts upon
depending on whether we are in the Installer or not.

When in the Installer, locking has to be skipped completely due to
missing typo3temp directory.

Resolves: #57008
Releases: 6.2
Change-Id: Ic595dc97826cd94d6f173b7c681194ed754ed3e0
Reviewed-on: https://review.typo3.org/28482
Reviewed-by: Christian Kuhn
Tested-by: Christian Kuhn
Reviewed-by: Markus Klein
Tested-by: Markus Klein

History

#1 Updated by Markus Klein over 5 years ago

  • Is Regression changed from No to Yes

Thanks Ernesto.

So this happens when installing a fresh 6.2?
The directory should actually be created by the Locker class.

#2 Updated by Gerrit Code Review over 5 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28482

#3 Updated by Gerrit Code Review over 5 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28482

#4 Updated by Gerrit Code Review over 5 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28482

#5 Updated by Gerrit Code Review over 5 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28482

#6 Updated by Gerrit Code Review over 5 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28482

#7 Updated by Gerrit Code Review over 5 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28482

#8 Updated by Gerrit Code Review over 5 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28482

#9 Updated by Gerrit Code Review over 5 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28482

#10 Updated by Gerrit Code Review over 5 years ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28482

#11 Updated by Alexander Opitz over 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#12 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF