Bug #57466

Exception: The requested jQuery version is not available in the local filesystem

Added by Stephan Gruber over 8 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2014-03-31
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

jQuery version 1.9.1 is missing in the $availableLocalJqueryVersions array in the PageRenderer although it is still among the available libraries in the contrib/ directory.

/**
* Array of jQuery version numbers shipped with the core
*
* @var array
*/
protected $availableLocalJqueryVersions = array(
    '1.8.2',    // jquery version shipped with TYPO3 6.0, still available in the contrib/ directory
    self::JQUERY_VERSION_LATEST
);
#1

Updated by Markus Klein over 8 years ago

May I ask what the bug behind this is? Is something not working?

#2

Updated by Markus Klein over 8 years ago

  • Status changed from New to Needs Feedback
#3

Updated by Stephan Gruber about 8 years ago

Well the bug is, that the FE crashes with the mentioned Exception when updating from Version 6.1.* where jQuery 1.9.1 was defined as "JQUERY_VERSION_LATEST".
Since 1.9.1 is still among the shipped versions, why not add it the array $availableLocalJqueryVersions and all is good.

#4

Updated by Markus Klein about 8 years ago

  • Status changed from Needs Feedback to Accepted

Hm, documentation says:

Note: jQuery.source has to be a CDN like "google" when jQuery.version is not "latest"

http://docs.typo3.org/typo3cms/TyposcriptReference/Setup/Page/Index.html#setup-page-javascriptlibs

So actually there's no guarantee that older versions are kept.

But I'm fine with adding this.

#5

Updated by Gerrit Code Review about 8 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29449

#6

Updated by Markus Klein about 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#7

Updated by Benni Mack almost 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF