Bug #57597

Fields of type 'select' with maxitems>1 and itemsProcFunc set work only, if items is set also

Added by Christjan Grabowski over 8 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2014-04-03
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I have a very similar problem to #15720 but with 6.2 .

My conf:

"config" => array (
    'type' => 'select',
    'items' => array(
    ),
    itemsProcFunc' => 'Tcahelper->getCountriesFromStaticInfoTables',
    'foreign_table' => 'static_countries',
    'foreign_table_where' => 'ORDER BY static_countries.cn_short_en',
    'allowNonIdValues' => TRUE,
    'size' => 30,
    'autoSizeMax' => 50,
    'minitems' => 1,
    'maxitems' => 500,
)

The "itemsProcFunc" changes the "uid" of static_info_tables to "cn_iso_2" (allowNonIdValues).
The correct "cn_iso_2" will be succesfully saved (comma seperated), but the Selected-Field
is empty again (maybe an error while allowing the values).

The setup works if i set maxitems to "1" (as dropdownbox)!

#1

Updated by Mathias Schreiber almost 7 years ago

  • Status changed from New to Resolved

when not using uids, there is no way of resolving these back.

#2

Updated by Christjan Grabowski over 6 years ago

I am a bit confused, cause with 4.5 this worked, and today with 7.6 my config-array ist working too.

So, i checked it for 6.2.15 and there it IS working. So it seemed to be a bug that ist resolved at another place.

Thanky anyway :)

#3

Updated by Benni Mack almost 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF