Bug #57830

Mailform

Added by Peter Linzenkirchner about 8 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Form Framework
Target version:
-
Start date:
2014-04-11
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

E-Mail ist not sent
Answerpage throws html in formfield - I presume wrong html-Tags.

Introduction Package 6.2:

Form:

prefix = tx_form
confirmation = 1
postProcessor {
    1 = mail
    1 {
        recipientEmail =mymail@domain.de
        senderEmail = inotheremail@domain.de
        subject = Der Betreff
    }
}
10 = FIELDSET
10 {
    10 = TEXTLINE
    10 {
        name = name
        value = Enter your name here
        label {
            value = Name
        }
    }
    20 = TEXTLINE
    20 {
        name = email
        label {
            value = E-Mail
        }
    }
    30 = TEXTAREA
    30 {
        cols = 40
        rows = 5
        name = enquiry
        label {
            value = Your enquiry
        }
    }
    40 = SUBMIT
    40 {
        name = submit
        value = Send Feedback
    }
}
rules {
    1 = required
    1 {
        breakOnError = 0
        showMessage = 1
        message = *
        error = This field is required
        element = name
    }
    2 = required
    2 {
        breakOnError = 0
        showMessage = 1
        message = *
        error = This field is required
        element = email
    }
    3 = email
    3 {
        breakOnError = 0
        showMessage = 
        message = (john.doe@domain.com)
        error = This is not a valid email address
        element = email
    }
    4 = required
    4 {
        breakOnError = 0
        showMessage = 1
        message = *
        error = This field is required
        element = enquiry
    }
}

Result: no e-Mail sent
Answerpage:

https://www.wuala.com/lisardo2/public/?key=lfXXhtarm2HT


Files

formmail-bug.png (91.8 KB) formmail-bug.png Screenshot Peter Linzenkirchner, 2014-04-11 14:32

Related issues

Is duplicate of TYPO3 Core - Bug #31951: Own checkbox layout breaks HTML mailClosed2011-11-20

Actions
#1

Updated by Markus Klein about 8 years ago

  • Status changed from New to Accepted

Had this issue too recently, but didn't have time to figure out if my config was wrong or not.

#2

Updated by Markus Klein about 8 years ago

  • Status changed from Accepted to Closed

I'm closing this as duplicate of #31951.
Please continue there. (watch that ticket)

Also available in: Atom PDF