Bug #57869

Remove side effects form TCA cache building

Added by Helmut Hummel about 8 years ago. Updated almost 8 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
Backend API
Target version:
-
Start date:
2014-04-12
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Files in Configuration/TCA/table_name.php are designed to only
introduce and define the TCA array of the given table.

It was never designed to change or override already introduced TCA.

This was however possible because the buildTca method uses
the global TCA array when assembling all arrays.

This possibility should be removed so that changing TCA
is only possible in ext_tables.php or the upcoming new
file as described in #57862


Related issues

Related to TYPO3 Core - Story #57862: Add possibility to make all TCA additions cachedClosed2014-04-12

Actions
Related to TYPO3 Core - Bug #58004: Categories not visibleClosed2014-04-17

Actions
#1

Updated by Gerrit Code Review about 8 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29435

#2

Updated by Gerrit Code Review about 8 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29435

#3

Updated by Helmut Hummel about 8 years ago

  • Status changed from Under Review to On Hold
#4

Updated by Helmut Hummel almost 8 years ago

  • Status changed from On Hold to Rejected

Also available in: Atom PDF