Bug #58403

Error while fetching permissions for

Added by Robert Peter over 7 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2014-05-01
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When running the 'Migrate all file links of RTE-enabled fields to FAL' wizard in the install tool it shows following exception:

Oops, an error occurred!
Error while fetching permissions for


Files

TYPO3_Exception_2.html (13.9 KB) TYPO3_Exception_2.html Robert Peter, 2014-05-02 21:13

Related issues

Related to TYPO3 Core - Bug #63335: Bug #58403Closed2014-11-26

Actions
#1

Updated by Markus Klein over 7 years ago

Please use the Development-Preset in the Install Tool to enable more detailed error reporting.
Please check your webserver error log for entries.

#2

Updated by Robert Peter over 7 years ago

Hey Markus,

Thanks for your answer. I activated the Development settings in Install Tool and the following errors were displayed:

#1319455097: Error while fetching permissions for (More information)
RuntimeException thrown in file
/path/to/typo3_src-6.2.1/typo3/sysext/core/Classes/Resource/Driver/LocalDriver.php in line 1097.
16 TYPO3\CMS\Core\Resource\Driver\LocalDriver::getPermissions("/")

00650:   }
00651:   // Check 4: "Folder permissions" of the driver
00652:   $folderPermissions = $this->driver->getPermissions($folder->getIdentifier());
00653:   if ($isReadCheck && !$folderPermissions['r']) {
00654:    return FALSE;
...

4 TYPO3\CMS\Install\Controller\Action\Tool\UpgradeWizard::executeAction()

3 TYPO3\CMS\Install\Controller\Action\AbstractAction::handle()

2 TYPO3\CMS\Install\Controller\ToolController::dispatchAuthenticationActions()

1 TYPO3\CMS\Install\Controller\ToolController::execute()

Enclosed you'll finde the complete file. Any thoughts on that?

#3

Updated by Markus Klein over 7 years ago

  • Status changed from New to Needs Feedback

Thx for the complete output.

I've have a suspicion what happened here.
Looks like there's something strange with your FAL storages.

Can you take a look which storages are there in the DB?
I suspect you have a storage for '/'. If so, please disable that storage.

Background information: The upgrader assumes that you have a storage for 'fileadmin/' as default storage.

#4

Updated by Robert Peter over 7 years ago

Hey Markus,

That was a very useful hint. I deactivated the second record in table "sys_file_storage". Afterwards the wizard performed the mentioned step completely. The question is, why the record "Bilder" was created in table "sys_file_storage" during the update process.

However, many thanks!

#5

Updated by Markus Klein over 7 years ago

I guess you executed some other upgrade wizard first that created this storage.

#6

Updated by Alexander Opitz about 7 years ago

  • Status changed from Needs Feedback to Closed
  • Target version deleted (next-patchlevel)

As the problem was fixed for you and no one else seams to have this issue, I'll close this one.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF