Bug #58913

Missing and invalid warnings on referenced files

Added by Oliver Hader over 5 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2014-05-19
Due date:
% Done:

100%

TYPO3 Version:
6.1
PHP Version:
5.3
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

The file list module in the backend offers the possibility to delete files. An interesting use case is the deletion of files that still have references to other entities. However, currently proper warnings are only available for sys_file reference.

a) before deleting a file, a popup should be shown
this does not work since the API is called with the identifier instead of a proper UID value

b) after calling the API for deleting a file, references should be pointed out
references are checked, however the description on the file usage is missing due to hardcoded "sys_file_reference" triggers - thus, no other references are printed out


Related issues

Related to TYPO3 Core - Bug #60919: References to files are sometimes wrong Closed 2014-08-12
Duplicated by TYPO3 Core - Bug #61048: using images in RTE doesn't prevent deleting Closed 2014-08-19

Associated revisions

Revision e26961c8 (diff)
Added by Oliver Hader about 5 years ago

[BUGFIX] Missing and invalid warnings on referenced files

The file list module in the backend offers the possibility to
delete files. An interesting use case is the deletion of files
that still have references to other entities. However, currently
proper warnings are only available for sys_file reference.

a) before deleting a file, a popup should be shown
this does not work since the API is called with
the identifier instead of a proper UID value

b) after calling the API for deleting a file, references
should be pointed out
references are checked, however the description on the
file usage is missing due to hardcoded "sys_file_reference"
triggers - thus, no other references are printed out

Resolves: #58913
Releases: master, 6.2, 6.1
Change-Id: Id80361427abc17bda3461c2d00750c4790798c88
Reviewed-on: http://review.typo3.org/30204
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

Revision a79bb23c (diff)
Added by Oliver Hader about 5 years ago

[BUGFIX] Missing and invalid warnings on referenced files

The file list module in the backend offers the possibility to
delete files. An interesting use case is the deletion of files
that still have references to other entities. However, currently
proper warnings are only available for sys_file reference.

a) before deleting a file, a popup should be shown
this does not work since the API is called with
the identifier instead of a proper UID value

b) after calling the API for deleting a file, references
should be pointed out
references are checked, however the description on the
file usage is missing due to hardcoded "sys_file_reference"
triggers - thus, no other references are printed out

Resolves: #58913
Releases: master, 6.2, 6.1
Change-Id: Id80361427abc17bda3461c2d00750c4790798c88
Reviewed-on: http://review.typo3.org/33495
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

Revision b0eb2878 (diff)
Added by Oliver Hader about 5 years ago

[BUGFIX] Missing and invalid warnings on referenced files

The file list module in the backend offers the possibility to
delete files. An interesting use case is the deletion of files
that still have references to other entities. However, currently
proper warnings are only available for sys_file reference.

a) before deleting a file, a popup should be shown
this does not work since the API is called with
the identifier instead of a proper UID value

b) after calling the API for deleting a file, references
should be pointed out
references are checked, however the description on the
file usage is missing due to hardcoded "sys_file_reference"
triggers - thus, no other references are printed out

Resolves: #58913
Releases: master, 6.2, 6.1
Change-Id: Id80361427abc17bda3461c2d00750c4790798c88
Reviewed-on: http://review.typo3.org/30205
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

History

#1 Updated by Gerrit Code Review over 5 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30204

#2 Updated by Gerrit Code Review over 5 years ago

Patch set 1 for branch TYPO3_6-1 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30205

#3 Updated by Oliver Hader over 5 years ago

  • Complexity set to easy

#4 Updated by Gerrit Code Review over 5 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30204

#5 Updated by Gerrit Code Review over 5 years ago

Patch set 2 for branch TYPO3_6-1 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30205

#6 Updated by Gerrit Code Review about 5 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/30204

#7 Updated by Gerrit Code Review about 5 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33495

#8 Updated by Gerrit Code Review about 5 years ago

Patch set 3 for branch TYPO3_6-1 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/30205

#9 Updated by Oliver Hader about 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#10 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF