Bug #59382

Page with overlayed mountpoint should not be accessible

Added by Alexander Stehlik about 6 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Frontend
Target version:
-
Start date:
2014-06-06
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When a page is of type mountpoint and the mountpoint overlay mode is enabled (so if the page is accessed the content of the mounted page is shown) this page should not be accessible.

Example:

  • Default page, UID: 1
  • Mountpoint page, UID: 2, mount_pid: 1, mount_pid_ol: 1

Now when opening http://mypage.tld?id=2 the user will see the page.

Expected result would be a redirection to the mountpoint context:

http://mypage.tld?id=1&MP=1-2

Associated revisions

Revision 963eb99e (diff)
Added by Alexander Stehlik over 5 years ago

[BUGFIX] Redirect on direct access to overlaid mountpoint

When the user directly accesses a page that is a mountpoint that
should be overlaid with the contents of the mounted page, he will
be redirected to the target page within the mounpoint context.

Releases: 6.3, 6.2
Resolves: #59382
Change-Id: Ie00c8210b39d2934b410d782799e4fc90efa8c5c
Reviewed-on: http://review.typo3.org/30603
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>

Revision 7d7cda38 (diff)
Added by Alexander Stehlik over 5 years ago

[BUGFIX] Redirect on direct access to overlaid mountpoint

When the user directly accesses a page that is a mountpoint that
should be overlaid with the contents of the mounted page, he will
be redirected to the target page within the mounpoint context.

Releases: master, 6.2
Resolves: #59382
Change-Id: Ie00c8210b39d2934b410d782799e4fc90efa8c5c
Reviewed-on: http://review.typo3.org/34458
Reviewed-by: Alexander Stehlik <>
Tested-by: Alexander Stehlik <>
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>

Revision 84909ef1 (diff)
Added by Alexander Stehlik over 5 years ago

[BUGFIX] Fix mountpoint overlay detection

This is a follow up to 963eb99e7d7f9ab3d4a50153412f0ed3b927b5e5.
The comparison for the doktype needs to be non strict because
the database row contains a string and the constant is an integer.

Releases: master
Resolves: #59382
Change-Id: I7727e6bfb8c3475602f576f6259824cf1c7d2ca3
Reviewed-on: http://review.typo3.org/35079
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>

History

#1 Updated by Gerrit Code Review about 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30603

#2 Updated by Gerrit Code Review about 6 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30603

#3 Updated by Gerrit Code Review almost 6 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30603

#4 Updated by Gerrit Code Review almost 6 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30603

#5 Updated by Gerrit Code Review almost 6 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/30603

#6 Updated by Gerrit Code Review almost 6 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/30603

#7 Updated by Gerrit Code Review over 5 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/30603

#8 Updated by Alexander Stehlik over 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#9 Updated by Gerrit Code Review over 5 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/34453

#10 Updated by Gerrit Code Review over 5 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/34458

#11 Updated by Gerrit Code Review over 5 years ago

Patch set 2 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/34458

#12 Updated by Gerrit Code Review over 5 years ago

Patch set 3 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/34458

#13 Updated by Gerrit Code Review over 5 years ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35079

#14 Updated by Alexander Stehlik over 5 years ago

  • Status changed from Under Review to Resolved

#15 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF