Project

General

Profile

Actions

Bug #59574

closed

RTE: JS exception raised in BlockStyle plugin regarding property disableStyleOnOptionLabel

Added by Sebastian Stelmasik over 9 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
Start date:
2014-06-14
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hi,
using own RTE-Configuration causes exceptions, as plugins try to check deprecated variable (disableStyleOnOptionLabel):

[root@mail web]# find ./typo3_src-6.2.3/typo3/sysext/rtehtmlarea/ -type f | xargs grep disableStyleOnOptionLabel
./typo3_src-6.2.3/typo3/sysext/rtehtmlarea/htmlarea/plugins/BlockStyle/block-style.js: if (!this.pageTSconfiguration.*disableStyleOnOptionLabel*) {
./typo3_src-6.2.3/typo3/sysext/rtehtmlarea/htmlarea/plugins/TextStyle/text-style.js: style: (!(this.pageTSconfiguration && this.pageTSconfiguration.*disableStyleOnOptionLabel*) && HTMLArea.classesValues && HTMLArea.classesValues[cssClass] && !HTMLArea.classesNoShow[cssClass]) ? HTMLArea.classesValues[cssClass] : null

This causes a JS exception which blocks Table injection s. http://forum.typo3.org/index.php/t/198506/

TypeError: this.pageTSconfiguration is undefined
if (!this.pageTSconfiguration.disableStyleOnOptionLabel) { merged...612 (Zeile 15064)

As a workaround I just commented out the if-clause.

Best regards,

Stelli

Actions #1

Updated by Stanislas Rolland over 9 years ago

  • Category set to RTE (rtehtmlarea + ckeditor)
Actions #2

Updated by Stanislas Rolland over 9 years ago

  • Subject changed from RTE JS-Plugins checking deprecated variable: disableStyleOnOptionLabel to RTE: JS exception raised in BlockStyle plugin regarding property disableStyleOnOptionLabel
  • Assignee set to Stanislas Rolland
  • Target version set to next-patchlevel

Property disableStyleOnOptionLabel is NOT deprecated.

The problem is that the BlockStyle plugin checks for this.pageTSconfiguration.disableStyleOnOptionLabel without checking first that this.pageTSconfiguration exists at all.

Actions #3

Updated by Gerrit Code Review over 9 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33915

Actions #4

Updated by Gerrit Code Review over 9 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33916

Actions #5

Updated by Stanislas Rolland over 9 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #6

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF