Bug #59826

Better index for sys_language

Added by Stefan Froemken almost 7 years ago. Updated almost 6 years ago.

Status:
Rejected
Priority:
Should have
Category:
Database API (Doctrine DBAL)
Target version:
Start date:
2014-06-23
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

Hello Core-Team,

I found a better index for sys_language

|        1 | 0.00040700 | SELECT sys_language.* FROM sys_language WHERE sys_language.hidden=0 ORDER BY sys_language.title |
|        2 | 0.00024000 | SELECT sys_language.* FROM sys_language WHERE sys_language.hidden=0 ORDER BY sys_language.title |

The sum of ALL cols of sys_language in an UTF-8 environment is 348 Byte. The max. allowed size for an index on a default environment of MySQL is 1024. So why not adding all cols in ONE index? So USING INDEX is also possible.

Stefan

#1

Updated by Gerrit Code Review almost 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/31086

#2

Updated by Wouter Wolters over 6 years ago

  • Status changed from Under Review to New
#3

Updated by Morton Jonuschat almost 6 years ago

  • Status changed from New to Rejected

Change has been abandoned due to missing feedback

Also available in: Atom PDF