Project

General

Profile

Actions

Bug #59831

closed

Package loading order is currupted by faulty patch #59147

Added by Markus Klein over 9 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
System/Bootstrap/Configuration
Target version:
Start date:
2014-06-24
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
medium
Is Regression:
Yes
Sprint Focus:

Description

The path saved to packagePathStack contains the package name, but is compared to the storage folder only.

Moreover the EM fails upon removing extensions, as we do not persist the packagePathStack information, we would need for that case. :-(


Related issues 1 (0 open1 closed)

Follows TYPO3 Core - Bug #59147: Wrong extension precedence in TYPO3 6.2Closed2014-05-27

Actions
Actions #1

Updated by Gerrit Code Review over 9 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/31097

Actions #2

Updated by Gerrit Code Review over 9 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/31098

Actions #3

Updated by Markus Klein over 9 years ago

  • Status changed from Under Review to Accepted
Actions #4

Updated by Markus Klein over 9 years ago

  • Status changed from Accepted to Under Review
Actions #5

Updated by Markus Klein over 9 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #6

Updated by Kasper Ligaard over 9 years ago

Is there a fair chance this will be solved within the coming weeks? I can live fine without the package-stuff (and I think most TYPO3 users would too), as long as it is made to work with TYPO3 extensions.

As it is right now, it is a nightmare to reliably use the Extension Manager - and it has been like that ever since October 2013, when the package-stuff was merged in to core :-(

PS: Is there an issue about printing the loading order within the Extension Manager (like there was in previous Extension Managers)?

Actions #7

Updated by Markus Klein over 9 years ago

  • Status changed from Resolved to Accepted

@Kasper Skårhøj, are you talking about #59147?
Please read my comments there.
Please do not post to this issue here, it is just here to document the revert of the original patch.

Actions #8

Updated by Markus Klein over 9 years ago

  • Status changed from Accepted to Resolved
Actions #9

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF