Bug #59849

Global renderReadonly in Tceforms doesn't affect tree

Added by Lorenz Ulrich almost 6 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2014-06-24
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The global renderReadonly status in Tceforms doesn't affect a rendered tree because the check was forgotten when #25888 was implemented.


Related issues

Related to TYPO3 Core - Bug #25888: TCA Tree readOnly not working Closed 2011-04-11

Associated revisions

Revision 50abc39c (diff)
Added by Lorenz Ulrich almost 6 years ago

[BUGFIX] Respect global renderReadonly in Tceforms for tree

The global renderReadonly status in Tceforms doesn't affect a
rendered tree because the check was forgotten when #25888 was
implemented. An additional check is added.

Resolves: #59849
Releases: 6.3, 6.2
Change-Id: Ic89ab2f39636dbbb7dc37941af8fe7be085fefcf
Reviewed-on: http://review.typo3.org/31110
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>
Reviewed-by: Stefan Neufeind <>
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

Revision 2af5f120 (diff)
Added by Lorenz Ulrich almost 6 years ago

[BUGFIX] Respect global renderReadonly in Tceforms for tree

The global renderReadonly status in Tceforms doesn't affect a
rendered tree because the check was forgotten when #25888 was
implemented. An additional check is added.

Resolves: #59849
Releases: 6.3, 6.2
Change-Id: Ic89ab2f39636dbbb7dc37941af8fe7be085fefcf
Reviewed-on: http://review.typo3.org/31815
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

History

#1 Updated by Gerrit Code Review almost 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/31110

#2 Updated by Lorenz Ulrich almost 6 years ago

Steps to reproduce:
Implement $GLOBALS['TYPO3_CONF_VARS']['SC_OPTIONS']['t3lib/class.t3lib_tceforms.php']['getMainFieldsClass'][] hook with this function:

    public function getMainFields_preProcess($table, $row, $parentObject) {
        /** @var $parentObject \TYPO3\CMS\Backend\Form\FormEngine */
        $parentObject->renderReadonly = TRUE;
    }

While most of the fields will be read-only, tree fields (and IRRE --> separate issue) and trees will be writable.

#3 Updated by Gerrit Code Review almost 6 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/31815

#4 Updated by Lorenz Ulrich almost 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF