Bug #59952

Extension manager - Get preconfigured distribution fails with "Sorry, the requested view was not found"

Added by Krzysztof Adamczyk over 5 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Extension Manager
Target version:
-
Start date:
2014-06-27
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When I try to install preconfigured distribution I received error :
"Sorry, the requested view was not found.The technical reason is: Array. "

Associated revisions

Revision b80ed35b (diff)
Added by Sascha Egerer over 5 years ago

[BUGFIX] Show errors on distribution installation

When you install a distribution and an error occurred, you get a fluid
error: "Sorry, the requested view was not found."

There is currently no template / view for the action. This patch renders
the error messages as flash messages and redirects to the list view of
distributions where the errors are shown.

Resolves: #59564
Resolves: #59952
Releases: 6.3, 6.2
Change-Id: Ie0e055dfd5620d4e0a08ecf87b2f458e7877ee76
Reviewed-on: https://review.typo3.org/31241
Reviewed-by: Wouter Wolters
Tested-by: Wouter Wolters

Revision 062cdfe3 (diff)
Added by Sascha Egerer over 5 years ago

[BUGFIX] Show errors on distribution installation

When you install a distribution and an error occurred, you get a fluid
error: "Sorry, the requested view was not found."

There is currently no template / view for the action. This patch renders
the error messages as flash messages and redirects to the list view of
distributions where the errors are shown.

Resolves: #59564
Resolves: #59952
Releases: 6.3, 6.2
Change-Id: Ie0e055dfd5620d4e0a08ecf87b2f458e7877ee76
Reviewed-on: https://review.typo3.org/31268
Reviewed-by: Wouter Wolters
Tested-by: Wouter Wolters

History

#1 Updated by Markus Klein over 5 years ago

Hi!

Which TYPO3 version are you using exactly and which distribution are you trying to install?

#2 Updated by Krzysztof Adamczyk over 5 years ago

Varsion : 6.3-dev
The problem concerns all packages

#3 Updated by Krzysztof Adamczyk over 5 years ago

Markus any idea where I can start looking a problem ?

#4 Updated by Markus Klein over 5 years ago

This is really weird, because the text is only present in the NotFoundView, which is only used in the ActionController.
There the errorMessage is set to a string. So no clue where the "Array." thing comes from.

You could start with setting a break point in the ActionController::resolveView() function and have a look at the backgrace.

#5 Updated by Chris topher over 5 years ago

  • Subject changed from Extension menager - Get preconfigured distribution to Extension manager - Get preconfigured distribution fails with "Sorry, the requested view was not found"
  • Category set to Extension Manager

#6 Updated by Nicole Cordes over 5 years ago

  • Status changed from New to Accepted
  • Assignee set to Nicole Cordes

#7 Updated by Gerrit Code Review over 5 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/31264

#8 Updated by Gerrit Code Review over 5 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/31264

#9 Updated by Gerrit Code Review over 5 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/31241

#10 Updated by Gerrit Code Review over 5 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/31241

#11 Updated by Gerrit Code Review over 5 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/31241

#12 Updated by Gerrit Code Review over 5 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/31268

#13 Updated by Anonymous over 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#14 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF