Project

General

Profile

Actions

Bug #60189

closed

Radio Button cant be Validate

Added by David Nagelschmidt over 9 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Fluid
Target version:
Start date:
2014-07-08
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
easy
Is Regression:
Yes
Sprint Focus:

Description

When the form is submitted without having to select a radio button.
Does not fetch the validation because the $_POST variable is not set by default.
This Bug exists only TYPO3 6.2.3, in Version 6.1.6 it works fine.

I have compare the files, but i dont found any different.

Actions #1

Updated by Alexander Opitz over 9 years ago

  • Project changed from 2559 to TYPO3 Core
  • Category changed from Fluid: ViewHelpers to Fluid
  • Target version changed from Fluid 6.2 to next-patchlevel
  • TYPO3 Version set to 6.2
  • Is Regression set to Yes
Actions #2

Updated by Claus Due over 8 years ago

  • Status changed from New to Closed

I'm not sure this was ever possible in TYPO3, or I suspect that it was not the same use case (e.g. hidden field existed, one radio had been checked, form data was not as expected, etc) - or at least, I'm not sure it was ever intended to be possible with the rewritten property mapper (that replaces the old, deprecated and removed one). In any case, speaking solely from the current status of things, it looks like this is by design. Each radio button is rendered individually indicating that if you wish a default value to be posed, you have two equally valid ways:

  • Manually render an f:form.hidden before the radios.
  • Set one of the radios' "checked" attribute to "checked".

The former may be simpler to implement but the latter would cause less HTML to be generated; both will apply with direct "name" attributes and "property" on objects. Use whichever one you feel applies best ;)

I will take the liberty of closing this issue since there are two ways to get the result and no changes are required in the source code.

Actions

Also available in: Atom PDF