Bug #60256

Argument 2 passed to mapRecordTypeToSpriteIconName() must be of the type array

Added by Marcin Sągol over 6 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend API
Target version:
-
Start date:
2014-07-11
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

After upgrade to 6.2.4 i can see some errors in Log module:

Core: Error handler (BE): PHP Catchable Fatal Error: Argument 2 passed to TYPO3\CMS\Backend\Utility\IconUtility::mapRecordTypeToSpriteIconName() must be of the type array, null given, called in /typo3_src-6.2.4/typo3/sysext/backend/Classes/Utility/IconUtility.php on line 841 and defined in /typo3_src-6.2.4/typo3/sysext/backend/Classes/Utility/IconUtility.php line 862

Core: Error handler (BE): PHP Catchable Fatal Error: Argument 2 passed to TYPO3\CMS\Backend\Utility\IconUtility::mapRecordTypeToSpriteIconClass() must be of the type array, null given, called in /typo3_src-6.2.4/typo3/sysext/backend/Classes/Utility/IconUtility.php on line 723 and defined in /typo3_src-6.2.4/typo3/sysext/backend/Classes/Utility/IconUtility.php line 840 Zmiany w plikach: latitude,longitude.

Core: Error handler (BE): PHP Catchable Fatal Error: Argument 2 passed to TYPO3\CMS\Version\Hook\IconUtilityHook::overrideIconOverlay() must be of the type array, null given, called in /typo3_src-6.2.4/typo3/sysext/backend/Classes/Utility/IconUtility.php on line 1004 and defined in /typo3_src-6.2.4/typo3/sysext/version/Classes/Hook/IconUtilityHook.php line 32

Core: Error handler (BE): PHP Catchable Fatal Error: Argument 2 passed to TYPO3\CMS\Backend\Utility\IconUtility::mapRecordOverlayToSpriteIconName() must be of the type array, null given, called in /typo3_src-6.2.4/typo3/sysext/backend/Classes/Utility/IconUtility.php on line 714 and defined in /typo3_src-6.2.4/typo3/sysext/backend/Classes/Utility/IconUtility.php line 947 Zmiany w plikach: latitude,longitude.

Core: Error handler (BE): PHP Catchable Fatal Error: Argument 2 passed to TYPO3\CMS\Backend\Utility\IconUtility::getSpriteIconForRecord() must be of the type array, null given, called in /typo3_src-6.2.4/typo3/sysext/core/Classes/Utility/File/ExtendedFileUtility.php on line 409 and defined in /typo3_src-6.2.4/typo3/sysext/backend/Classes/Utility/IconUtility.php line 710

#1

Updated by Mathias Schreiber about 5 years ago

  • Target version deleted (next-patchlevel)
#2

Updated by Wouter Wolters almost 5 years ago

  • Status changed from New to Closed

Since only a few had this problem and 6.2 is in low prio mode I close this issue.
We have a complete new IconAPI in version 7, so there this piece of code is gone.

Also available in: Atom PDF