Bug #60382

Shortcut is displayed like a regular page if isn't a shortcut in the original language

Added by Christoph Buchli about 8 years ago. Updated almost 7 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
Frontend
Target version:
Start date:
2014-07-18
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
nightmare
Is Regression:
No
Sprint Focus:

Description

Reproduce the Bug like this:
- Translate any regular page to any language
- Modify the pages_language_overlay record to make it a shortcut
- Call the page in the Frontend (e.g.: http://example.com/?id=5&L=1)

You will experience, that this page is being displayed altough it is supposed to be a shortcut.

I've tried to fix the issue by adding doktype,shortcut,shortcut_mode to TYPO3_CONF_VARS->FE->pageOverlayFields but this didn't work like expected either.


Related issues

Related to TYPO3 Core - Bug #60258: showAccessRestrictedPages with shortcuts to restricted pagesResolved2014-07-11

Actions
Related to TYPO3 Core - Bug #32406: Menus not working in translated pages for type "shortcut"Closed2011-12-08

Actions
#1

Updated by Markus Klein almost 8 years ago

  • Target version deleted (next-patchlevel)

I invested quite some time now on this topic, but I must admit, this is not easily solvable with the current code structure.

Prerequisite is to have doktype in TYPO3_CONF_VARS->FE->pageOverlayFields, but this does not help anymore since the language handling happens after the actual page has been determined. That is, the doktype (changed by the page overlay) is not considered anymore.
If we consider the doctype at this place again, this would require a complete restart of the processing queue, because of caching, mountpoints, shortcuts (again) and so on.

IMHO this requires severe restructuring of the FrontendRequestHandler, which is not an option for released versions like 6.2.
AFAIK the bootstrap process is on a todo list for refactoring, maybe this is solvable this way.

Cheers
Markus

#2

Updated by Markus Klein over 7 years ago

  • Status changed from New to Accepted
  • Target version set to 7 LTS
  • Complexity set to nightmare
#3

Updated by Mathias Schreiber almost 7 years ago

  • Status changed from Accepted to Rejected

This isn't how translation work (nor should work).
A translation should change content, not functionality.

Also available in: Atom PDF