Bug #60443

Extensionmanager offers to turn off dependency checks even if dependencies already met

Added by Jost Baron over 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Extension Manager
Target version:
-
Start date:
2014-07-21
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I've written an extension that requires EXT:vhs. So in my ext_emconf.php I put this:

    'constraints' => array(
        'depends' => array(
            'php' => '5.3.7',
            'typo3' => '6.2.4-6.2.999',
            'cms' => '',
            'fluidcontent' => '4.0.0',
            'vhs' => '1.9.1',
            'flux' => '7.0.0',
        ),
        'conflicts' => array(
        ),
        'suggests' => array(
        ),
    ),

When trying to install my extension, I get this message:


    Required extension "vhs":
        * The extension vhs is needed in version 1.9.1 - , but could not be fetched from TER

The problem is, that EXT:vhs is already installed and running, and its version is 1.9.1.

I could work around the problem in two ways:

  1. Remove the version from the vhs dependency, so it ready 'vhs' => ''
  2. Uninstall vhs, but not delete it. Haven't tried to delete it.

Happens in TYPO3 6.2.4, with PHP 5.3.27.

History

#1 Updated by Susanne Moog over 5 years ago

  • Category set to Extension Manager

#2 Updated by Mathias Schreiber about 5 years ago

  • Status changed from New to Closed

Taken into account in #63909.
The issues are not linked on purpose, so the refactoring ticket does not get bloated with relations.

Also available in: Atom PDF