Bug #60487

File References override meta data with empty string per default

Added by Oliver Hader over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2014-07-23
Due date:
% Done:

0%

TYPO3 Version:
6.1
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

On creating a new file reference (e.g. inside a tt_content element with images), the file reference properties "title", "description" and "alternative" are set to an empty string which results in overriding the meta data of the original file per default. The solution is to allow NULL as default value, which is currently casted to string if being creating as new IRRE child record.


Related issues

Duplicates TYPO3 Core - Bug #54412: Improve default value handling for NULL value fields Closed 2013-12-14

History

#1 Updated by Oliver Hader over 5 years ago

  • Subject changed from File References override meta data with empty string per defaul to File References override meta data with empty string per default

#2 Updated by Markus Klein over 5 years ago

Hi Olly!

I'm not sure if I read this correctly, but I disagree. Currently the meta data are empty yes, but they do not override since the override checkbox is not enabled by default.

#3 Updated by Oliver Hader over 5 years ago

  • Status changed from New to Closed
  • TYPO3 Version changed from 6.2 to 6.1

Markus Klein wrote:

Hi Olly!

I'm not sure if I read this correctly, but I disagree. Currently the meta data are empty yes, but they do not override since the override checkbox is not enabled by default.

That's right... I experienced that in a TYPO3 6.1 project where there related issue #54412 has not been back-ported to.
Since the default value could only be a string up to TYPO3 6.2, there's unfortunately no way to back-port it.

A cherry-pick for TYPO3 6.1 can be found here however:
https://github.com/ohader/TYPO3.CMS/commit/372ea7b1150aa3176569b6e16cc4129b030b0994

Also available in: Atom PDF