Project

General

Profile

Actions

Bug #60702

closed

Clicking on pencil results in "Sorry, you didn't have proper permissions to perform this change."

Added by Gerwin Kramer over 9 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend User Interface
Target version:
Start date:
2014-07-31
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.5
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

When I'm using the Page module and I click on the pencil of the third (or higher) content item, i get this message: "Sorry, you didn't have proper permissions to perform this change."

Note: no problems in the context menu->edit or List module.

The error is caused by typo3/sysext/backend/Classes/View/PageLayoutView.php line 1313:

$params = '&edit[tt_content][' . $this->tt_contentData['nextThree'][$row['uid']] . ']=edit';

It appears that $this->tt_contentData['nextThree'] is empty at the third content item. An easy fix would be to replace $this->tt_contentData['nextThree'][$row['uid']] with $row['uid']

Out of curiosity, what is the function of this 'nextThree'?


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #60199: Page module: tt_content records are not editableClosedJigal van Hemert2014-07-09

Actions
Actions #1

Updated by Markus Klein over 9 years ago

Seems to be related to #60199

Actions #2

Updated by Jigal van Hemert over 9 years ago

  • Status changed from New to Closed

Closed as duplicate of #60199 .

And regarding your question: the nextThree data contains information about the content elements around a content element; these are specifically made for the icons for moving, editing, and so on. The name is a relic from the past :-)

If you have extra information, please add it to #60199 . This way we can keep the number of duplicate issues down to a minimum.

Actions

Also available in: Atom PDF