Project

General

Profile

Actions

Bug #60764

closed

\TYPO3\CMS\Core\Resource\Index::processChangedAndNewFiles() not indexing files with same hash

Added by Frank Nägler almost 10 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2014-08-04
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

currently the \TYPO3\CMS\Core\Resource\Index::processChangedAndNewFiles() use file hash to check if a file in a storage exists. If files found the missing flag is checked and the method break out if a missing file was found.

the problem is, that a new file with same content but in an other folder or a new file with same content but other filename will never be indexed.
This happens for files in a storage, which should be indexed by \TYPO3\CMS\Scheduler\Task\FileStorageIndexingTask.


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #54415: File indexer does not detect indentical files in the other storagesClosed2013-12-14

Actions
Actions #1

Updated by Gerrit Code Review almost 10 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32000

Actions #2

Updated by Gerrit Code Review almost 10 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32000

Actions #3

Updated by Gerrit Code Review almost 10 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32269

Actions #4

Updated by Frans Saris almost 10 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #5

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF