Bug #61117

Missing stdWrap for 'where' in select query

Added by Kilian Hann over 7 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Frontend
Target version:
-
Start date:
2014-08-21
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Similar to #55707 the 'where' part of the select statement is not on the list in ContentObjectRenderer->getQuery:

$properties = array(
    'pidInList',
    'uidInList',
    'languageField',
    'selectFields',
    'max',
    'begin',
    'groupBy',
    'orderBy',
    'join',
    'leftjoin',
    'rightjoin',
    'where' <-- Added as example
);

(although mentioned in the documentation: http://docs.typo3.org/typo3cms/TyposcriptReference/Functions/Select/Index.html)


Files

patch-where.diff (834 Bytes) patch-where.diff Kilian Hann, 2014-08-21 13:26

Related issues

Related to TYPO3 Core - Bug #55707: Missing stdWrap for recursive in select queryClosed2014-02-05

Actions
#1

Updated by Gerrit Code Review over 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32296

#2

Updated by Gerrit Code Review over 7 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32296

#3

Updated by Kilian Hann over 7 years ago

forget about this issue, 'where' is handled differently.

It seems to be a different issue, the not interpreted stdWrap occurred after a Formhandler upgrade

#4

Updated by Gerrit Code Review over 7 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32296

#5

Updated by Gerrit Code Review over 7 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32593

#6

Updated by Kilian Hann over 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#7

Updated by Benni Mack over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF