Project

General

Profile

Actions

Bug #55707

closed

Missing stdWrap for recursive in select query

Added by Matthias Kappenberg about 10 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
TypoScript
Target version:
Start date:
2014-02-05
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.1
PHP Version:
Tags:
Complexity:
no-brainer
Is Regression:
No
Sprint Focus:

Description

typo3/sysext/frontend/Classes/ContentObject/ContentObjectRenderer.php

Line 7397 ++
public function getQuery($table, $conf, $returnQueryArray = FALSE) {
// Resolve stdWrap in these properties first
$properties = array(
'pidInList',
'uidInList',
'languageField',
'selectFields',
'max',
'begin',
'groupBy',
'orderBy',
'join',
'leftjoin',
'rightjoin',
'recursive' <-----THIS IS MISSING, ADDED AS EXAMPLE
);

recursive is not on the list...
which means
A: Change the manual here:
http://docs.typo3.org/typo3cms/TyposcriptReference/Functions/Select/Index.html

Property recursive Since TYPO3 4.6: integer /stdWrap

or
B: Please add recursive to the list...

Many thanks and best regards,
Matthias


Files

Core_Issue_ID_55707.diff (799 Bytes) Core_Issue_ID_55707.diff Matthias Kappenberg, 2014-02-14 14:55

Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Feature #18822: Add stdWrap to each of the properties of TypoScript "select"ClosedErnesto Baschny2008-05-21

Actions
Related to TYPO3 Core - Bug #61117: Missing stdWrap for 'where' in select queryClosed2014-08-21

Actions
Actions #1

Updated by Markus Klein about 10 years ago

Hi Matthias!

Would you mind pushing your patch to our review system?
http://wiki.typo3.org/CWT

Actions #2

Updated by Matthias Kappenberg about 10 years ago

Hi Markus,

thank you for the answer :-)

Is the attached file correct?
Or should I commit it via git?

Best regards,
Matthias

Actions #3

Updated by Oliver Hader almost 10 years ago

It seems that "recursive" just has been forgotten in the original change of issue #18822 for TYPO3 CMS 4.6
Thus, it's at least not a regression since it never worked with stdWrap on "recursive". Thus, either add it to 6.1/6.2 or remove it from the documentations.

Actions #4

Updated by Gerrit Code Review almost 10 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30043

Actions #5

Updated by Gerrit Code Review almost 10 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30043

Actions #6

Updated by Oliver Hader almost 10 years ago

  • Is Regression changed from Yes to No
Actions #7

Updated by Gerrit Code Review over 9 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/30043

Actions #8

Updated by Gerrit Code Review over 9 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/30043

Actions #9

Updated by Gerrit Code Review over 9 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/30043

Actions #10

Updated by Gerrit Code Review over 9 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32209

Actions #11

Updated by Gerrit Code Review over 9 years ago

Patch set 1 for branch TYPO3_6-1 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32210

Actions #12

Updated by Matthias Kappenberg over 9 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #13

Updated by Chris topher about 9 years ago

stdWrap for the recursive property had already been documented in TSref (see Documentation/Functions/Select/Index.rst). I have just fixed the wrong "Since TYPO3 4.5/4.6" comment in https://github.com/TYPO3-Documentation/TYPO3CMS-Reference-Typoscript/commit/291efe4296baba42b58d925057ebd2236ffa33bf and in the backports back to 4.7.

Actions #14

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF