Bug #61276

TCA property "exclusiveKeys" prevents from selecting an item

Added by most wanted almost 7 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
Start date:
2014-08-29
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.3
Tags:
Complexity:
no-brainer
Is Regression:
Yes
Sprint Focus:

Description

In the TYPO3 backend the TCA property "exclusiveKeys" of column type "select" prevents a backend user from selecting an item if only one key is set.

It expects a string (list of) but only works if it is set to at least two keys seperated by a comma.

  • works: 'exclusiveKeys' => '-1,-999'
  • does not work: 'exclusiveKeys' => '-1'

"Does not work" means that no item can be selected at all - a JavaScript error is thrown instead.

Enclosed please find a screenshot of the error message the Chrome developer tools show.


Files


Related issues

Related to TYPO3 Core - Task #46357: Move TCEForms JS Code to external file - part 1ClosedBenni Mack2013-03-16

Actions
#1

Updated by most wanted almost 7 years ago

This Bug seems to be introduced with TYPO3 6.2 - worked with TYPO3 6.1.? before.

#2

Updated by Markus Klein almost 7 years ago

Which variable is undefined in the screenshot?

The related change is https://review.typo3.org/18971
But the code seems to be a 1:1 copy of the previous code, except that the configuration (incl. excludedKeys) are now handed over to JS via data-* attributes.

#3

Updated by most wanted almost 7 years ago

Markus Klein wrote:

Which variable is undefined in the screenshot?

Sorry, I am not able to check this before the upcomming weekend.

#4

Updated by Markus Klein almost 7 years ago

  • Status changed from New to Needs Feedback
#5

Updated by Gerrit Code Review almost 7 years ago

  • Status changed from Needs Feedback to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32591

#6

Updated by Gerrit Code Review almost 7 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32591

#7

Updated by Markus Klein almost 7 years ago

  • Complexity set to no-brainer
  • Is Regression changed from No to Yes
#8

Updated by Gerrit Code Review almost 7 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32600

#9

Updated by most wanted almost 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#10

Updated by Benni Mack almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF