Project

General

Profile

Actions

Bug #61385

closed

Frontend Output of EXT:form broken

Added by Matthias Krappitz over 9 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Form Framework
Target version:
Start date:
2014-09-06
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Using TYPO3 6.2.4 and EXT:form in an installation with no third party extension installed and very simple basic TS page object using FLUIDTEMPLATE the entire frontend output of a very simple form by EXT:form is broken. Instead of the desired markup it outputs a mixture of some wrapping divs and the original Typoscript configuring the form. The current version of css_styled_content static Typoscript is included in root template.
Example:
http://typo3.aemka.de/index.php?id=8
Output of EXT:form:

<div id="c1" class="csc-default"><h1 class="csc-firstHeader">Test</h1><form action="seite-1.html" id="mailform" name="mailform" enctype="multipart/form-data" method="post" onsubmit="return validateForm('mailform','','','','')"><div style="display:none;"><input type="hidden" name="locationData" value="8:tt_content:1" /></div><fieldset class="csc-mailform"><div class="csc-mailform-label">enctype = multipart/form-data</div><div class="csc-mailform-label">method = post</div><div class="csc-mailform-label">prefix = tx_form</div><div class="csc-mailform-label">confirmation =</div><div class="csc-mailform-label">postProcessor {</div><div class="csc-mailform-label">1 = mail</div><div class="csc-mailform-label">1 {</div><div class="csc-mailform-label">recipientEmail = info@aemka.de</div><div class="csc-mailform-label">senderEmail = info@aemka.de</div><div class="csc-mailform-label">subject = Test</div><div class="csc-mailform-label">}</div><div class="csc-mailform-label">}</div><div class="csc-mailform-label">10 = TEXTLINE</div><div class="csc-mailform-label">10 {</div><div class="csc-mailform-label">name = test</div><div class="csc-mailform-label">label {</div><div class="csc-mailform-label">value = Test</div><div class="csc-mailform-label">}</div><div class="csc-mailform-label">}</div><div class="csc-mailform-label">20 = SUBMIT</div><div class="csc-mailform-label">20 {</div><div class="csc-mailform-label">name = 3</div><div class="csc-mailform-label">value = Formular absenden</div><div class="csc-mailform-label">}</div></fieldset></form></div>

Actions #1

Updated by Matthias Krappitz over 9 years ago

Tell me what else info to provide to help to track this down.

Actions #2

Updated by Matthias Krappitz over 9 years ago

  • % Done changed from 0 to 100

Please close, it's not a bug. Found the non core-related error in this elsewhere.

Actions #3

Updated by Mathias Schreiber about 9 years ago

  • Status changed from New to Closed
Actions #4

Updated by Björn Jacob over 8 years ago

  • Category changed from Form Framework to 1602
Actions #5

Updated by Björn Jacob almost 8 years ago

  • Category changed from 1602 to Form Framework
Actions

Also available in: Atom PDF