Task #62914

Early check for PHP 5.5 in Install Tool

Added by Xavier Perseguers over 5 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
Start date:
2014-11-13
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
5.5
Tags:
Complexity:
Sprint Focus:

Description

As PHP 5.5 is now a requirement for TYPO3 CMS, add an early check in Install Tool.


Related issues

Duplicated by TYPO3 Core - Bug #64504: PHP 5.4 fatals with unexpected 'class' (T_CLASS) instead of proper error Closed 2015-01-26

Associated revisions

Revision 98e27d3a (diff)
Added by Xavier Perseguers over 5 years ago

[!!!][TASK] Early check for PHP 5.5 in Install Tool

PHP 5.5 or above is a requirement for TYPO3 CMS. As code is using
specific PHP 5.5 features, an early check is required in Install Tool.

Releases: master
Resolves: #62914
Change-Id: Ia33b5e16d5cc96edc7cad5a4348fce5fb1b1236a
Reviewed-on: http://review.typo3.org/34056
Reviewed-by: Benjamin Mack <>
Reviewed-by: Wouter Wolters <>
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>
Reviewed-by: Xavier Perseguers <>
Tested-by: Xavier Perseguers <>

History

#1 Updated by Gerrit Code Review over 5 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/34056

#2 Updated by Gerrit Code Review over 5 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/34056

#3 Updated by Xavier Perseguers over 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF