Bug #62984

PHP warning on saving TypoScript with t3editor

Added by Oliver Hader about 5 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
t3editor
Target version:
Start date:
2014-11-15
Due date:
% Done:

100%

TYPO3 Version:
4.5
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

On saving TypoScript data in the accordant backend module using t3editor, the AJAX call issues a PHP warning "Creating default object from empty value". This only happens if at least PHP 5.4 is used. The reason is, that an uninitialized and empty variable is used for object access.

Associated revisions

Revision 42de3e0d (diff)
Added by Oliver Hader about 5 years ago

[BUGFIX] PHP warning on saving TypoScript with t3editor

On saving TypoScript data in the accordant backend module
using t3editor, the AJAX call issues a PHP warning
"Creating default object from empty value". This only
happens if at least PHP 5.4 is used. The reason is,
that an uninitialized and empty variable is used for
object access.

Resolves: #62984
Releasses: 4.5
Change-Id: I7567d61f0a16379db58760dd963f0330dc8ca6c8
Reviewed-on: http://review.typo3.org/34203
Reviewed-by: Oliver Hader <>
Tested-by: Oliver Hader <>

History

#1 Updated by Gerrit Code Review about 5 years ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_4-5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/34203

#2 Updated by Oliver Hader about 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#3 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF