Bug #63306

frontend does not check for file:123 format when parsing html

Added by Nils Blattner over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Frontend
Target version:
-
Start date:
2014-11-24
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hi there

The sysext frontend does not check that "<link file:"-links actually contain a numeric value (when parsing RTE output) and just forces it to be a FAL-link automatically.
If one uses the possibility of "file:\\netmount\foo\bar.doc" links, the rendered bodytext just contains the text, as there was no FAL-record (uid = 0) found.

Attached patch solves at least the frontend output.

Cheers

20141124-ContentObjectRenderer.php.diff View (601 Bytes) Nils Blattner, 2014-11-24 17:33

History

#1 Updated by Tizian Schmidlin over 4 years ago

Actually, is_int is too aggressive and since $linkHandlerValue is a string it will never match. Use this instead:

            if ($linkHandlerKeyword === 'file' && \TYPO3\CMS\Core\Utility\MathUtility::canBeInterpretedAsInteger($linkHandlerValue)) {

#2 Updated by Riccardo De Contardi over 4 years ago

  • Status changed from New to Needs Feedback
  • Assignee set to Nils Blattner

Could you tell us if this could be closed? Thank you

#3 Updated by Nils Blattner over 4 years ago

Should be OK in the latest 6.2.

Cheers

#4 Updated by Riccardo De Contardi over 4 years ago

  • Status changed from Needs Feedback to Closed

Thank you Nils; I close it for now.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF