Project

General

Profile

Actions

Bug #63368

closed

Dependencies are not considered for empty contraints

Added by Franz Holzinger over 9 years ago. Updated about 9 years ago.

Status:
Rejected
Priority:
Must have
Assignee:
-
Category:
Extension Manager
Target version:
Start date:
2014-11-27
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

An extension is forced to have the dependancies set for the TYPO3 version. However if nothing has been set, then the extension is still installed.

The extension should not be installed. But an error message should be shown.

Dependencies could not be resolved
Your TYPO3 version is higher than allowed. You can use TYPO3 versions 0.0.3 - 0.0.3

However I can still install such an extension and get:

ast_rteproducts installed.
Your installation of ast_rteproducts was successful.

Log:
Extensions installed:

    ast_rteproducts

E.g these extensions should not be installable:

ast_rteproducts, onet_ttproducts_rte, c3bi_cookie_at_login

    'constraints' => 
    array (
        'depends' => 
        array (
        ),
        'conflicts' => 
        array (
        ),
        'suggests' => 
        array (
        ),
    ),
Actions

Also available in: Atom PDF