Bug #63383

Protocol relative url no longer working in page.includeCSS

Added by Charles Brunet about 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2014-11-28
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I just upgraded to 6.2.7, and protocol relative url are no longer included from TypoScript.

Example:

page.includeCSS.font-awesome = http://maxcdn.bootstrapcdn.com/font-awesome/4.2.0/css/font-awesome.min.css

works but

page.includeCSS.font-awesome = //maxcdn.bootstrapcdn.com/font-awesome/4.2.0/css/font-awesome.min.css

no longer includes the CSS file.

#1

Updated by Henrik Ziegenhain about 6 years ago

Thanks for your report, but I cannot reproduce it.
Exactly your example is working fine for me in 6.2.7

I think, you have forgotten the .external option.

Please try

page.includeCSS {
  font-awesome = //maxcdn.bootstrapcdn.com/font-awesome/4.2.0/css/font-awesome.min.css
  font-awesome.external = 1
}

See http://docs.typo3.org/typo3cms/TyposcriptReference/Setup/Page/Index.html#includecss-array
.external: If set, there is no file existence check. Useful for inclusion of external files.

Following the docs, I think the behavior was wrong BEFORE 6.2.7

#2

Updated by Markus Klein almost 6 years ago

  • Status changed from New to Needs Feedback
  • Is Regression changed from Yes to No

Still an issue on 6.2.11?

#3

Updated by Charles Brunet almost 6 years ago

Yes, you are right. This is because it was working without the .external parameter before. The issue can be closed.

#4

Updated by Riccardo De Contardi over 5 years ago

  • Status changed from Needs Feedback to Closed

Also available in: Atom PDF