Bug #63927

Story #63815: Reduce communication between server and client

Remove Last-Modified response header from cached output

Added by Patrick Broens almost 5 years ago. Updated 12 months ago.

Status:
Closed
Priority:
Must have
Category:
-
Target version:
-
Start date:
2014-12-16
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The current state of last-modified is broken by design.

Furthermore it is the question if we should support this properly at all in the future, since well, the whole page has to be rendered anyway to find out if it 'was-modified-since' so there is no benefit on server side (and not on client side either). Supporting that would also mean that we need to track/hash basically everything, so it would be a really evil cross-cutting-concern that affects extensions, content, files, everything.

A document is added to this issue explaining the whole situation

Browser caching.pdf (71.5 KB) Patrick Broens, 2014-12-16 12:30

Associated revisions

Revision c4faf452 (diff)
Added by Patrick Broens over 4 years ago

[BUGFIX] Last-Modified response header broken by design

The Last-Modifed header needs to change whenever there is a change
related to that page. Not only the page properties or records located
on that page, but every change which should be reflected on that page,
like menus, TypoScript or layout. Currently this is not happening and
has huge impact to make it work.

This patch removes the Last-Modified response header. The ETag response
header has kind of the same function, so no harm is done by deleting
Last-Modified.

Resolves: #63927
Releases: master, 6.2
Change-Id: Ic5d14225c2f90cc63e1c4413d5426565ea5e1e41
Reviewed-on: http://review.typo3.org/38265
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>
Reviewed-by: Andreas Fernandez <>
Tested-by: Andreas Fernandez <>

Revision d643a32f (diff)
Added by Patrick Broens over 4 years ago

[BUGFIX] Last-Modified response header broken by design

The Last-Modifed header needs to change whenever there is a change
related to that page. Not only the page properties or records located
on that page, but every change which should be reflected on that page,
like menus, TypoScript or layout. Currently this is not happening and
has huge impact to make it work.

This patch removes the Last-Modified response header. The ETag response
header has kind of the same function, so no harm is done by deleting
Last-Modified.

Resolves: #63927
Releases: master, 6.2
Change-Id: Ic5d14225c2f90cc63e1c4413d5426565ea5e1e41
Reviewed-on: http://review.typo3.org/38269
Reviewed-by: Andreas Fernandez <>
Tested-by: Andreas Fernandez <>

History

#1 Updated by Patrick Broens almost 5 years ago

  • Parent task set to #63815

#2 Updated by Patrick Broens almost 5 years ago

  • Assignee set to Patrick Broens

#3 Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38265

#4 Updated by Gerrit Code Review over 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38265

#5 Updated by Gerrit Code Review over 4 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38269

#6 Updated by Patrick Broens over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#7 Updated by Benni Mack 12 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF