Project

General

Profile

Actions

Bug #64323

closed

Argument "displayCond" not work into other "flux:form.sheet"

Added by Vasyl Mosiychuk over 9 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2015-01-16
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I have code:

[...]
<flux:form.sheet name="options1">
    <flux:field.checkbox name="checkbox1" default="1" requestUpdate="TRUE" />
    <flux:field.checkbox name="checkbox2" default="0" displayCond="FIELD:checkbox1:=:1" />
</flux:form.sheet>
<flux:form.sheet name="options2">
    <flux:field.input name="input1" displayCond="FIELD:checkbox1:=:1" />
    <flux:field.input name="input2" />
</flux:form.sheet>
[...]

Argument "displayCond" for field ""options2" -> "input1" not work into other group fields ""options1" -> "checkbox1""

What is that, error or ...???


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #42333: Flexform displayConditionRejected2012-10-24

Actions
Actions #1

Updated by Sven Burkert almost 9 years ago

I think this is a bug of extension flux / fluidcontent.
Perhaps you should post this error here: https://github.com/FluidTYPO3/flux/issues

Sorry, I understand now, you have been asked by the FluidTYPO3 team to post this bug here (see https://github.com/FluidTYPO3/flux/issues/732)

Actions #2

Updated by Claus Due over 8 years ago

  • Category changed from Fluid to FormEngine aka TCEforms

Absolutely not related to Fluid in any way. I'm not sure that FormEngine is the correct category either so please forgive if that's incorrect.

Actions #3

Updated by Morton Jonuschat over 8 years ago

  • Status changed from New to Closed

This is the intended behavior. DisplayCond in FlexForm has two "levels". If you use a displayCond to decide wether a whole sheet should be shown/hidden then you have access to the values of all sheets using FIELD:sheetName.fieldName, if you use displayCond on on a field you only have access to the fields on that sheet (plus the database fields with parentRec.fieldName).

Your example tries to access the field "checkbox1" from sheet "options1" within the sheet "options2", which is why it's not working.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Actions

Also available in: Atom PDF