Bug #64904

indexed search experimental advanced search is not working

Added by Tymoteusz Motylewski over 4 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2015-02-06
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
Stabilization Sprint

Associated revisions

Revision c0eef29e (diff)
Added by Tymoteusz Motylewski over 4 years ago

[BUGFIX] Make advanced search work with indexed_search extbase plugin

Resolves: #64904
Releases: master
Change-Id: Idd3ea31071fa37bca3e9e2aa807ab3afea561b76
Reviewed-on: http://review.typo3.org/36713
Reviewed-by: Mathias Schreiber <>
Tested-by: Mathias Schreiber <>
Reviewed-by: Göran Bodenschatz <>
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>

Revision 3febc799 (diff)
Added by Tymoteusz Motylewski over 4 years ago

[BUGFIX] Make advanced search work with indexed_search extbase plugin

Resolves: #64904
Releases: master,6.2
Change-Id: Idd3ea31071fa37bca3e9e2aa807ab3afea561b76
Reviewed-on: http://review.typo3.org/38661
Reviewed-by: Tymoteusz Motylewski <>
Tested-by: Tymoteusz Motylewski <>

History

#1 Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/36713

#2 Updated by Tymoteusz Motylewski over 4 years ago

  • Sprint Focus set to Stabilization Sprint

#3 Updated by Tymoteusz Motylewski over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Gerrit Code Review over 4 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38661

#5 Updated by Tymoteusz Motylewski over 4 years ago

  • Status changed from Under Review to Resolved

#6 Updated by André Steiling almost 4 years ago

Hello there,

the advanced search delivers results, but what about the advanced search options? They aren't in the result, because action "search" is called and "search" doesn't have the routine to assign these options, isn't it?

Routine in action "form" - it doesn't appear in action "search", so the advanced options are gone after submit:
if ($search['extendedSearch']) {
// "Search for"
$allSearchTypes = $this->getAllAvailableSearchTypeOptions();
$this->view->assign('allSearchTypes', $allSearchTypes);
$allDefaultOperands = $this->getAllAvailableOperandsOptions();
$this->view->assign('allDefaultOperands', $allDefaultOperands);
$showTypeSearch = count($allSearchTypes) || count($allDefaultOperands);
$this->view->assign('showTypeSearch', $showTypeSearch);
// "Search in"
$allMediaTypes = $this->getAllAvailableMediaTypesOptions();
$this->view->assign('allMediaTypes', $allMediaTypes);
$allLanguageUids = $this->getAllAvailableLanguageOptions();
$this->view->assign('allLanguageUids', $allLanguageUids);
$showMediaAndLanguageSearch = count($allMediaTypes) || count($allLanguageUids);
$this->view->assign('showMediaAndLanguageSearch', $showMediaAndLanguageSearch);
// Sections
$allSections = $this->getAllAvailableSectionsOptions();
$this->view->assign('allSections', $allSections);
// Free Indexing Configurations
$allIndexConfigurations = $this->getAllAvailableIndexConfigurationsOptions();
$this->view->assign('allIndexConfigurations', $allIndexConfigurations);
// Sorting
$allSortOrders = $this->getAllAvailableSortOrderOptions();
$this->view->assign('allSortOrders', $allSortOrders);
$allSortDescendings = $this->getAllAvailableSortDescendingOptions();
$this->view->assign('allSortDescendings', $allSortDescendings);
$showSortOrders = count($allSortOrders) || count($allSortDescendings);
$this->view->assign('showSortOrders', $showSortOrders);
// Limits
$allNumberOfResults = $this->getAllAvailableNumberOfResultsOptions();
$this->view->assign('allNumberOfResults', $allNumberOfResults);
$allGroups = $this->getAllAvailableGroupOptions();
$this->view->assign('allGroups', $allGroups);
}

Maybe a protected "helper" could solve the problem for both actions, but I'm not in deep into the code and I don't find any hint oder issue addressing this problem - so it's a bug or something I configure in a wrong way ...?

Greetings,
André

#7 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF