Bug #65877

Warning when trying to download documentation for extension in TYPO3 7.2

Added by Tymoteusz Motylewski over 4 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2015-03-20
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

How to reproduce:
1. Go to documentation module
2. switch to "download documentation"
3. search for indexed search
4. click on the download button
5. you will get an error

Download failed

The documentation for "typo3cms.extensions.indexed_search" could not be downloaded, because of the following error: PHP Warning: Invalid argument supplied for foreach() in typo3/sysext/documentation/Classes/Service/DocumentationService.php line 119 (1).

Associated revisions

Revision 8f417995 (diff)
Added by Tymoteusz Motylewski over 4 years ago

[BUGFIX] Download documentation for extension in documentation module

Fix the warning when trying to download documentation
for extension in TYPO3 7.2

Resolves: #65877
Releases: master
Change-Id: I98624eb8f0bd5bddd5390151f9cb09b86f6b279e
Reviewed-on: http://review.typo3.org/37980
Reviewed-by: Peter Kraume <>
Tested-by: Peter Kraume <>
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>

History

#1 Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37980

#2 Updated by Tymoteusz Motylewski over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#3 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF