Bug #66023

Performance issue with caching empty text menus

Added by Oliver Hader over 4 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2015-03-25
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
5.5
Tags:
Complexity:
medium
Is Regression:
No
Sprint Focus:

Description

If a text menu level is defined in TypoScript but does not return any pages, the result value is NULL instead of the expected empty array. Since the check whether to reprocess a menu expects an array, the generation process is triggered again, invalidates the cache entry and adds the very same NULL value to the cache.

The solution is to define a default empty array value for text menu levels.


Related issues

Related to TYPO3 Core - Bug #63550: Menu configuration caching disabled by ineffective type checks Closed 2014-12-03

Associated revisions

Revision 1f98368e (diff)
Added by Oliver Hader over 4 years ago

[BUGFIX] Performance issue with caching empty text menus

If a text menu level is defined in TypoScript but does not
return any pages, the result value is NULL instead of the
expected empty array. Since the check whether to reprocess
a menu expects an array, the generation process is triggered
again, invalidates the cache entry and adds the very same NULL
value to the cache.

The solution is to define a default empty array value for text
menu levels.

Resolves: #66023
Releases: 6.2
Change-Id: I66abb6fe7c1a91544b02193573ec601fb3240d98
Reviewed-on: http://review.typo3.org/38159
Reviewed-by: Oliver Hader <>
Tested-by: Oliver Hader <>

History

#2 Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38159

#3 Updated by Oliver Hader over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF