Bug #66124

Serialization of 'Closure' is not allowed in GifBuilder

Added by Gerald Loß over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Frontend
Target version:
-
Start date:
2015-03-29
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

For the flag images of my language menu, I got always the following failure from the method \TYPO3\CMS\Core\Utility\GeneralUtility\GifBuilder->fileName().

Serialization of 'Closure' is not allowed.

I think the reason is, there are some anonymous functions in any of the classes \TYPO3\CMS\Core\Resource\File or \TYPO3\CMS\Core\Resource\ProcessedFile which are included in the array setup. You try to serialize this array.
I have found a workaround for myself. I transform the array setup with implode before I serialize it. But I cannot say, if this would lead to trouble in ohter situations. Therefore I know to less about this coding.
Please have a look into the attached dokument. There can you see the workaround from me and the content of the array setup.

Exactly Typo Version is 7.1.0


Files

Error_For_GifBuilder.pdf (99.2 KB) Error_For_GifBuilder.pdf Gerald Loß, 2015-03-29 22:55

Related issues

Is duplicate of TYPO3 Core - Bug #65535: Exception: Serialization of 'Closure' is not allowedClosed2015-03-05

Actions
#1

Updated by Markus Klein over 6 years ago

  • Status changed from New to Closed

Seems to be a duplicate of #65535

Also available in: Atom PDF