Bug #65535

Exception: Serialization of 'Closure' is not allowed

Added by Stefan Froemken about 6 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2015-03-05
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hello,

I wanted to test following issue https://review.typo3.org/#/c/37483/
With contained TypoScript my TYPO3 master throws following Exception:

Exception: Serialization of 'Closure' is not allowed

The exception was thrown in last line of GifBuilder->fileName():

public function fileName($pre) {
    /** @var $basicFileFunctions \TYPO3\CMS\Core\Utility\File\BasicFileUtility */
    $basicFileFunctions = GeneralUtility::makeInstance('TYPO3\\CMS\\Core\\Utility\\File\\BasicFileUtility');
    $filePrefix = implode('_', array_merge($this->combinedTextStrings, $this->combinedFileNames));
    $filePrefix = $basicFileFunctions->cleanFileName($filePrefix);

    return $this->tempPath . $pre . $filePrefix . '_' . GeneralUtility::shortMD5(serialize($this->setup)) . '.' . $this->extension();
}

IMO the line 225 is the problem:

$this->setup[$theKey . '.']['BBOX'] = $fileInfo;

Here you fill in the complete FAL-System with all recursive/needed Objects. Again: We fill Objects into our lovely text-based TypoScript Array.

With following patch: https://review.typo3.org/#/c/37485/ the Exception will not appear anymore, but the problem is still there. The Objects are still there. After serializing this structure we have a nearly 100KB string which is needed ONLY to create a unique hash for a file.

Stefan


Related issues

Related to TYPO3 Core - Bug #65378: Scaling/cropping images in GIFBUILDER does not workClosed2015-02-27

Actions
Related to TYPO3 Core - Bug #65473: Remove closure in signalSlotDispatcherClosedNicole Cordes2015-03-03

Actions
Has duplicate TYPO3 Core - Bug #66124: Serialization of 'Closure' is not allowed in GifBuilderClosed2015-03-29

Actions
#1

Updated by Gerrit Code Review about 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37556

#2

Updated by Susanne Moog almost 6 years ago

  • Target version changed from 7.4 (Backend) to 7.5
#3

Updated by Benni Mack over 5 years ago

  • Sprint Focus set to Stabilization Sprint
#4

Updated by Benni Mack over 5 years ago

  • Target version changed from 7.5 to 7 LTS
  • Sprint Focus deleted (Stabilization Sprint)
#5

Updated by Riccardo De Contardi over 3 years ago

  • Status changed from Under Review to Closed
  • Assignee deleted (Nicole Cordes)
  • Target version deleted (7 LTS)

We think it is safe to close this issue; the patch has been abandoned as not needed anymore, thus the issue
is no more relevant.

If you think that this is the wrong decision or experience this issue again on recent TYPO3 versions like 8.7.x and 9.0.0,
please reopen it or open a new issue with a reference to this one.

Also available in: Atom PDF