Bug #66435

Epic #77562: Misbehaviors with datetime values and timezones

Scheduler Task - Cron Command for recurring tasks not evaluated correctly

Added by Alex B almost 5 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
scheduler
Target version:
-
Start date:
2015-04-15
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hi,

when creating a task in the scheduler, set it to recurring and use a cron command, the next execution is displayed and executed wrong.
The resulting execution time is also dependend on the current time when the task is saved.

The cron command e.g.:
*/10 * * * 4
which translates to: run every 10 minutes on thursdays, so it should start at 0:00 thursdays, then 0:10, 0:20, ...
But when i save the task the next run is stated for the correct day, but with a start time from the current time.

Example:
it is now: 15.04.2015 12:45
saving the above cron command the next execution is: 16.04.2015 12:50
which is the correct day but wrong time. And this is not only a display problem. The execution really starts there.

Even stranger:
if i save with the following command at 12:45h:
/10 8-11 * * 4
the next execution is correctly stated at: 16-04-15 08:00
if i save this one
/10 8-12 * * 4
i get the next execution wrong at this time: 16-04-15 12:50

Cheers & Thank you

Alex

History

#1 Updated by Alex B almost 5 years ago

cron command from above is always */10...

#2 Updated by Andreas Dörler over 4 years ago

Hi,

we also see "funny" behaviour on creating scheduler tasks.

We have to set frequency to 30 22 * * * if we want the task to be executed everyday at 00:30.
Timezone on Server ist CEST (Europe/Vienna, GMT +02:00), so it looks like the next execution time is calculated in GMT.

Caution: After saving the task, the next execution time is "correctly" set to 22:30 as configured in the frequency field.
After first run of the cli command, the next execution time gets updated with the wrong value.

Tested on Typo3 6.2.11 and Typo3 7.0.2.

If there is anything else you need for testing, please let me know.
Andreas

#3 Updated by Riccardo De Contardi over 2 years ago

  • Parent task set to #77562

#4 Updated by Markus Klein over 2 years ago

  • Status changed from New to Needs Feedback

Is this still the case on TYPO3 v7 or v8?

Are you sure that your PHP configuration (timezone specifically) is identical for WEB and CLI context?

#5 Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Needs Feedback to Closed

No feedback since 90 days => closed.

If you think that this is the wrong decision or experience the issue again or have more information about how to reproduce it, then please reopen it or open a new issue with a reference to this one. Thank you.

Also available in: Atom PDF