Bug #66586

Conditions used in TSConfig not working on TCEFORM

Added by Christian Stern over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
TypoScript
Target version:
Start date:
2015-04-25
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
no-brainer
Is Regression:
No
Sprint Focus:

Description

I have definied some costum elements via mod.wizards.newContentElement.wizardItems. Those elements should only appear in colPos 1337 for example.

[globalVar = GP:colPos == 1337]
mod.wizards.newContentElement.wizardItems {
    awesome {
        header = Special
        elements {
            this {
                title = This
                description = That
            }
        }
    }
    awesome.show = this
}
[global]

This is working as aspected. My next approach was disable some fields in this element, because they are never needed.

So i put TCEFORM.tt_content.header_link.disabled = 1 into the same condition.

[globalVar = GP:colPos == 1337]
TCEFORM.tt_content.header_link.disabled = 1
[global]

This is not working but using TCEFORM outside the condition is working.

Is there anyway to use TCEFORM-settings with condtions differentiating colpos?

#1

Updated by Christian Stern over 7 years ago

  • % Done changed from 0 to 100

narf Okay, it was a nobrainer.

The following condition works in TSConfig to check against colPos.

[globalVar = GP:defVals|tt_content|colPos==1337]
TCEFORM.tt_content.header_link.disabled = 1
[global]

#2

Updated by Mathias Schreiber over 7 years ago

  • Status changed from New to Closed

Also available in: Atom PDF