Bug #66695

Infinite loop for non-admins in filelist

Added by Nicole Cordes almost 5 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2015-04-30
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

If you have a storage which defines the processed folder in another storage an infinite loop occurs when accessing the file list.

Associated revisions

Revision 3d50d1f6 (diff)
Added by Nicole Cordes almost 5 years ago

[BUGFIX] Prevent infinite loop in FAL access check

If you have a storage which defines the processed folder in another
storage an infinite loop occurs when accessing the file list as
non-admin user. This is because the function getProcessingFolders
is called within the access check and starts access check for the
processed folder as well. This patch creates folder objects without
any access check (because processed folders should be readable and
writeable for everyone). Furthermore the processed folders for a storage
are cached after first fetch.

Releases: master, 6.2
Resolves: #66695
Change-Id: I9dade448466160f8c66f6118622d074f52bff702
Reviewed-on: http://review.typo3.org/39109
Reviewed-by: Helmut Hummel <>
Reviewed-by: Frans Saris <>
Reviewed-by: Markus Klein <>
Tested-by: Frans Saris <>
Tested-by: Markus Klein <>

Revision f0a98e86 (diff)
Added by Nicole Cordes almost 5 years ago

[BUGFIX] Prevent infinite loop in FAL access check

If you have a storage which defines the processed folder in another
storage an infinite loop occurs when accessing the file list as
non-admin user. This is because the function getProcessingFolders
is called within the access check and starts access check for the
processed folder as well. This patch creates folder objects without
any access check (because processed folders should be readable and
writeable for everyone). Furthermore the processed folders for a storage
are cached after first fetch.

Releases: master, 6.2
Resolves: #66695
Change-Id: I9dade448466160f8c66f6118622d074f52bff702
Reviewed-on: http://review.typo3.org/39243
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>

History

#1 Updated by Gerrit Code Review almost 5 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/39109

#2 Updated by Gerrit Code Review almost 5 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/39109

#3 Updated by Gerrit Code Review almost 5 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/39243

#4 Updated by Nicole Cordes almost 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Anja Leichsenring about 4 years ago

  • Sprint Focus deleted (On Location Sprint)

#6 Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF