Bug #67237

BE upload not possible when minitems=1

Added by Stefan Rosbak over 6 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2015-06-02
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

If one configures a field in the TCA with type=group, internal_type=file and minitems=1, the upload field displayed in the BE form does not work. You can select an upload from the element browser, but not direclty upload a new file.

Example TCA to reproduce:
'image' => array(
'exclude' => 1,
'label' => 'Image',
'config' => array(
'type' => 'group',
'internal_type' => 'file',
'allowed' => $GLOBALS['TYPO3_CONF_VARS']['GFX']['imagefile_ext'],
'max_size' => $GLOBALS['TYPO3_CONF_VARS']['BE']['maxFileSize'],
'uploadfolder' => 'uploads/tx_extkey',
'show_thumbs' => 1,
'size' => 1,
'minitems' => 1,
'maxitems' => 1,
)
),


Related issues

Related to TYPO3 Core - Bug #66832: Fileupload in a record fails with TCA for "exactly one file" (minitems/maxitems=1)Closed2015-05-07

Actions
Related to TYPO3 Core - Bug #68795: The fields marked with a yellow exclamation mark are not yet correctly filled in. Please complete them properly.Closed2015-08-06

Actions
#1

Updated by Riccardo De Contardi about 6 years ago

  • Status changed from New to Closed

I close this as a duplicate of #66832; please continue the discussion there; I made a relation to #66832 to keep track of it.
If you think that this is the wrong decision, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF