Bug #67546

Cleanup Flash message rendering in FlashMessageQueue

Added by Helmut Hummel almost 4 years ago. Updated 6 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend API
Target version:
-
Start date:
2015-06-17
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Streamline rendering of FlashMessages to the same output
the view helper creates by default currently.

This makes usage of HTML in flash messages not possible any more
when FlashMessageQueue::renderFlashMessages() is used, because
all HTML entities will now be properly HTML encoded.

Associated revisions

Revision 8bef7587 (diff)
Added by Helmut Hummel over 3 years ago

[!!!][TASK] Cleanup Flash message rendering in FlashMessageQueue

Streamline rendering of FlashMessages to the same output
the view helper creates by default currently.

This makes usage of HTML in flash messages not possible any more
when FlashMessageQueue::renderFlashMessages() is used, because
all HTML entities will now be properly HTML encoded.

Also adapt DocumentTemplate to use the new rendering
and remove the deprecated div wrapper with id.

Resolves: #67546
Related: #63453
Releases: master
Change-Id: I999f1b394c23e964cced30e74351fd6bfb2cd645
Reviewed-on: http://review.typo3.org/40341
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>
Reviewed-by: Benjamin Mack <>
Tested-by: Benjamin Mack <>

History

#1 Updated by Gerrit Code Review almost 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/40341

#2 Updated by Gerrit Code Review almost 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/40341

#3 Updated by Helmut Hummel over 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Benni Mack 6 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF