Bug #67801

ForViewHelper always counts all items

Added by Mathias Brodala over 4 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Category:
Fluid
Target version:
Start date:
2015-06-29
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

Quoting from https://jira.neos.io/browse/FLOW-325:

When using the iteration argument, the ForViewHelper provides information about the current iteration, including the cycle and total results. Therefore it needs to count all elements.
The problem is, that this happens even if the iteration argument is not specified leading to performance issues especially when iterating over a (subset of a) lot of (remote) items.

Associated revisions

Revision 6ea4f290 (diff)
Added by Mathias Brodala over 4 years ago

[BUGFIX] Only count items in ForViewHelper when ``iteration`` argument is set

When using the ``iteration`` argument, the ``ForViewHelper`` provides
information about the current iteration, including the ``cycle`` and
``total``. Therefore it needs to count all elements.
The problem is, that this happens even if the iteration argument is
not specified leading to performance issues especially when iterating
over a (subset of a) lot of (remote) items.

This patch fixes this by adding a check for the ``iteration`` argument.

Resolves: #67801
Releases: master, 6.2
Change-Id: I4645ed03322bea36f2c36263378900f401626f24
Reviewed-on: http://review.typo3.org/40711
Reviewed-by: David Greiner <>
Tested-by: David Greiner <>
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>

Revision 3db88fe1 (diff)
Added by Mathias Brodala over 4 years ago

[BUGFIX] Only count items in ForViewHelper when ``iteration`` argument is set

When using the ``iteration`` argument, the ``ForViewHelper`` provides
information about the current iteration, including the ``cycle`` and
``total``. Therefore it needs to count all elements.
The problem is, that this happens even if the iteration argument is
not specified leading to performance issues especially when iterating
over a (subset of a) lot of (remote) items.

This patch fixes this by adding a check for the ``iteration`` argument.

Resolves: #67801
Releases: master, 6.2
Change-Id: I4645ed03322bea36f2c36263378900f401626f24
Reviewed-on: http://review.typo3.org/40718
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>

History

#1 Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/40711

#2 Updated by Gerrit Code Review over 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/40711

#3 Updated by Gerrit Code Review over 4 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/40718

#4 Updated by Mathias Brodala over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 50 to 100

#5 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF