Bug #67881

CategoryRegistry is empty when TCA is read from cache

Added by Alexander Stehlik almost 5 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Category:
Categorization API
Target version:
-
Start date:
2015-07-02
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
5.5
Tags:
Complexity:
medium
Is Regression:
No
Sprint Focus:

Description

The CategoryRegistry is filled during the initial build of the TCA.

When the TCA is read from the cache the CategoryRegistry will not be filled.

This is a problem because the itemsProcFunc of tt_content.category_field relies on the values stored in the category registry.

Steps to reproduce:

  • Create a content element with the CType "menu" and select one of the category menu types
  • The select field "Category field" does probably not contain any items.
  • Now clear the system cache
  • And reload the Frame displaying the Form
  • Now the value "Categories" should be selectable for "Category field" (the expected behavior)
  • Save the content element
  • Now the select field says "INVALID VALUE ("categories")

Related issues

Related to TYPO3 Core - Bug #70034: Problem with makeCategorizable in TYPO3 6.2.15 Closed 2015-09-23

Associated revisions

Revision 791f3576 (diff)
Added by Alexander Stehlik over 4 years ago

[BUGFIX] Cache CategoryRegistry state together with TCA

The CategoryRegistry is stored together with the final TCA in
the cache.

This is needed because the registry is filled during the initial
build of the TCA and not when the TCA is loaded from the cache.

Resolves: #67881
Releases: master, 6.2
Change-Id: Ic7f341a1710cafbc1a1ea150e003d3d7a7b9c458
Reviewed-on: http://review.typo3.org/40845
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>
Reviewed-by: Wouter Wolters <>
Reviewed-by: Helmut Hummel <>
Tested-by: Helmut Hummel <>

Revision 095b7812 (diff)
Added by Alexander Stehlik over 4 years ago

[BUGFIX] Cache CategoryRegistry state together with TCA

The CategoryRegistry is stored together with the final TCA in
the cache.

This is needed because the registry is filled during the initial
build of the TCA and not when the TCA is loaded from the cache.

Resolves: #67881
Releases: master, 6.2
Change-Id: Ic7f341a1710cafbc1a1ea150e003d3d7a7b9c458
Reviewed-on: http://review.typo3.org/43070
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>
Reviewed-by: Helmut Hummel <>
Tested-by: Helmut Hummel <>

History

#1 Updated by Gerrit Code Review almost 5 years ago

  • Status changed from New to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/40845

#2 Updated by Gerrit Code Review almost 5 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/40845

#3 Updated by Gerrit Code Review almost 5 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/40845

#4 Updated by Gerrit Code Review almost 5 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/40845

#5 Updated by Gerrit Code Review over 4 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/40845

#6 Updated by Markus Sommer over 4 years ago

  • Description updated (diff)
  • Assignee set to Alexander Stehlik

#7 Updated by Gerrit Code Review over 4 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43070

#8 Updated by Alexander Stehlik over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#9 Updated by Gerrit Code Review over 4 years ago

  • Status changed from Resolved to Under Review

Patch set 2 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43070

#10 Updated by Gerrit Code Review over 4 years ago

Patch set 3 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43070

#11 Updated by Alexander Stehlik over 4 years ago

  • Status changed from Under Review to Resolved

#12 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF