Bug #67962

editIconsHook in FileList not usable anymore

Added by Nicole Cordes over 4 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2015-07-07
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

In 4.5 you could get the current file/folder with fileList->eCounter and fileList->dirs. With FAL those properties aren't set anymore and there is no way to decide to add an icon in addiction to the current file/folder. The current FAL object should be passed to the hook method to be able to work with the current object.

Associated revisions

Revision 9082bf1e (diff)
Added by Nicole Cordes over 4 years ago

[BUGFIX] Make editIconsHook work again

It isn't possible to add icons in filelist extended view easily,
because there is no way to get the current file or folder object nor get
information about it. This patch adds the object to the cells variable
and reset it after hook execution to ensure access to it.

Releases: master, 6.2
Resolves: #67962
Change-Id: I44a4229128bcfdb2ed17900462f50a771ed63fdd
Reviewed-on: http://review.typo3.org/41117
Reviewed-by: Wouter Wolters <>
Reviewed-by: Andreas Fernandez <>
Reviewed-by: Helmut Hummel <>
Tested-by: Helmut Hummel <>

Revision 170283bc (diff)
Added by Nicole Cordes over 4 years ago

[BUGFIX] Make editIconsHook work again

It isn't possible to add icons in filelist extended view easily,
because there is no way to get the current file or folder object nor get
information about it. This patch adds the object to the cells variable
and reset it after hook execution to ensure access to it.

Releases: master, 6.2
Resolves: #67962
Change-Id: I44a4229128bcfdb2ed17900462f50a771ed63fdd
Reviewed-on: http://review.typo3.org/42589
Reviewed-by: Nicole Cordes <>
Tested-by: Nicole Cordes <>
Reviewed-by: Helmut Hummel <>
Tested-by: Helmut Hummel <>

History

#1 Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/41117

#2 Updated by Nicole Cordes over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#3 Updated by Mathias Schreiber over 4 years ago

  • Sprint Focus deleted (On Location Sprint)

#4 Updated by Gerrit Code Review over 4 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/42589

#5 Updated by Nicole Cordes over 4 years ago

  • Status changed from Under Review to Resolved

#6 Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF