Bug #68009

In draft workspace, nest Fluid content

Added by dan frost over 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Workspaces
Target version:
-
Start date:
2015-07-09
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I have nested fluid elements, one parent with two child elements in two slots: “left” and “right”. When in a draft workspace I can edit each element and publish it fine. But when in draft workspace if I reorder the elements or drag on from the left to right or vice versa i get a problem. It happens when I try to publish - I get "" is not a valid template resource URI and "The server did not send any response whether the action was successful"

After this I have duplicates (which I think are references since clicking delete on one of them, deletes two).

But before I delete them, I tried to edit and got “you don’t have permissions…"

History

#1 Updated by Jost Baron over 4 years ago

I think this belongs to the fluidcontent-extension.

#2 Updated by Riccardo De Contardi about 4 years ago

  • Status changed from New to Needs Feedback
  • Assignee set to dan frost

Dan, what extension are you using to render fluid content? flux/fluidcontent?

#3 Updated by Oliver Hader about 4 years ago

  • Status changed from Needs Feedback to Closed

I don't know much about Flux et al, but it used a lot of DataHandler hooks to do "things" (as mentioned, I'm not of aware of these provider things etc.):
https://github.com/FluidTYPO3/flux/blob/development/Classes/Backend/TceMain.php

So, it might be the case something in the core is wrong on handling FlexForms/XML - the thing with duplicates in workspaces sounds more like placeholders that have not been resolved correctly.
That's why I'm closing this issue for the core and ask you to file an issue there. If you think it's a core thingy, please reopen the issue and provide all the configuration/dump that is required to reproduce and analyze the behavior. Thx

Also available in: Atom PDF