Bug #68367

checkSubmit should wait 500ms

Added by Marco Huber about 4 years ago. Updated over 3 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2015-07-19
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Steps to reproduce:
Create a new record which has a required field. Insert something in the required field. Click on save. The alert "The fields marked with an exclamation mark are not yet correctly filled in. Please complete them properly." is shown.

You have to click somewhere else before you click on save.

Because of the setTimeout in typo3/sysext/backend/Resources/Public/JavaScript/FormEngineValidation.js Line 59-62 around "FormEngineValidation.validate();" the checkSubmit function should also wait 500ms before it tries to submit the form.

issue_68367.png View (190 KB) Marco Huber, 2015-07-19 12:51


Related issues

Duplicates TYPO3 Core - Bug #68599: Validation in formengine wrong without leaving field Closed 2015-07-28

History

#1 Updated by Marco Huber about 4 years ago

#2 Updated by Gerrit Code Review about 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/41703

#3 Updated by Markus Sommer about 4 years ago

  • Assignee set to Marco Huber

#4 Updated by Frank Naegler over 3 years ago

  • Status changed from Under Review to Rejected

rejected, because a refactoring of the validation stuff is planed for CMS 8

Also available in: Atom PDF