Bug #68599

Validation in formengine wrong without leaving field

Added by Georg Ringer about 4 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
-
Target version:
Start date:
2015-07-28
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:
Stabilization Sprint

Description

If a record got a required field, e.g. the title, and a user adds some text in the field and clicks the save button directly after writing, the validation still complains!

leaving the field makes it then possible to save.


Related issues

Duplicated by TYPO3 Core - Bug #68367: checkSubmit should wait 500ms Rejected 2015-07-19

Associated revisions

Revision 5487fbd2 (diff)
Added by Frank Naegler about 4 years ago

[BUGFIX] Validation in formengine without leaving field

Fix validation problem for input fields.

Resolves: #68599
Releases: master
Change-Id: I8e4f77d7c2b68d2f1e36ef52ad3bef3bf0d51a58
Reviewed-on: http://review.typo3.org/42075
Reviewed-by: Josef Glatz <>
Tested-by: Josef Glatz <>
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

History

#2 Updated by Gerrit Code Review about 4 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/42075

#3 Updated by Frank Naegler about 4 years ago

  • Assignee set to Frank Naegler

#4 Updated by Frank Naegler about 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF