Bug #68544

File upload doesn't work in IE 11

Added by Inge Khodjasteh over 6 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2015-07-27
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hi there,

file upload doesn't work in IE 11. The file seems to be uploaded 100%, but the progress bar doesn't change into "green" and after refresh the file cannot be found in the directory.

Best regards
alexinge


Files

fileupload-IE11.JPG (66.8 KB) fileupload-IE11.JPG Inge Khodjasteh, 2015-07-27 09:52
konsole.JPG (25 KB) konsole.JPG Inge Khodjasteh, 2015-07-30 13:32
network-panel1.JPG (144 KB) network-panel1.JPG Inge Khodjasteh, 2015-07-31 10:32
network-panel2-afterr-refresh.JPG (187 KB) network-panel2-afterr-refresh.JPG Inge Khodjasteh, 2015-07-31 10:32
Bildschirmfoto 2015-10-22 um 11.53.43.png (44.4 KB) Bildschirmfoto 2015-10-22 um 11.53.43.png F12 Entwicklertools Vendy Tjung, 2015-10-22 12:01
#1

Updated by Markus Klein over 6 years ago

  • Status changed from New to Needs Feedback

I'm can't reproduce this problem. Can you maybe check the error logs (server, typo3temp/logs/, Log module) if there is some info?

#2

Updated by Inge Khodjasteh over 6 years ago

I'm sorry, but there aren't any entries in errorlog.txt nor typo3temp/logs/typo3.log. The protocol only states the login, but no error!

#3

Updated by Markus Klein over 6 years ago

Are you accessing the page with IE compatibility mode?
(this is turned on by default for intranet sites)

#4

Updated by Inge Khodjasteh over 6 years ago

Yes, I've turned it off, but the problem still exists...
The upload works, when I'm editing content and do an upload within this editing process, but not in file list.

#5

Updated by Markus Klein over 6 years ago

Can you check with Dev Tools of IE if there are any javascript errors?

#6

Updated by Inge Khodjasteh over 6 years ago

Hi, I'm sorry I've got no experience with Dev Tools. I only found this message:

SCRIPT1010: Bezeichner erwartet
Datei: mod.php, Zeile 1, Spalte 9

!?

#7

Updated by Markus Klein over 6 years ago

I've seen this error before, but it does not seem to cause real issues.
This is rather not related to file upload.

If you keep the network panel (or however this is named in IE) open while uploading, do you see any failing request?

#9

Updated by Markus Klein over 6 years ago

  • Target version deleted (6.2.14)

Ok the AJAX request is never completed. Does it work with any other browser on this machine?

#10

Updated by Inge Khodjasteh over 6 years ago

Yes, it works in Chrome and Firefox. Didn't test the other browser's. The problem occurs at work, but not at home. Maybe it's a configuration problem in the office network!?

#11

Updated by Riccardo De Contardi over 6 years ago

some security settings of IE, maybe?

#12

Updated by Dietma Haimann over 6 years ago

Hi! We have the same problem here. Did you ever got this problem solved? Because of this problem we must deploy FF. Are there any updates or workaraounds to this case available?

Thanks! Dietmar

#13

Updated by Markus Klein over 6 years ago

Since we fail to reproduce that, I'm pretty sure Riccardo is right and there is some security setting involved.

we must deploy FF

Why so "negative"? Actually I would take this chance and ban IE completely from the environment, especially in a government organization.

#14

Updated by Dietma Haimann over 6 years ago

Why so "negative"

It is strategy to use (only) IE to minimize support for too many browsers. It's hard enough. Mozilla never released Group Policy Objects to centrally manage FF. A must have in a government organization with many users with different needs.

We placed the Typo3-Pages in the trusted sites zone. Which security settings do you mean? Which settings must be allowed to make this working?

Thanks!

#15

Updated by Markus Klein over 6 years ago

AFAIK GPO is supported by Chrome, so that could be a standalone alternative maybe.

I can't tell you the exact setting, since I can't reproduce this. I suggest to open the IE dev panel and watch the network traffic there. Especially check the AJAX requests and their result. This might give a hint on why uploads fail.
There was a report about some IE problem recently and it turned out that a anti-virus software addon for IE was the culprit. Are you running any addons in IE?

#16

Updated by Dietma Haimann over 6 years ago

I think it's not necessary to justify why we use IE. We do so and it's much better than its reputation.
No there are no anti-virus addons running in IE. I will investigate the traffic with F12 tools and try to send feedback if I am able to find anything.

Cheers, Dietmar

#17

Updated by Vendy Tjung over 6 years ago

I can also reproduce this problem with IE 11, though upload status more than 100% (sometimes 105%). The files with color orange are not uploaded.
I uploaded also the ajax request, the request with only red progress bar are the missing files. It's seem that the request doesn't return any value.

Any idea?

#18

Updated by Riccardo De Contardi about 6 years ago

I am not able to reproduce the problem with TYPO3 6.2.17 and the latest 8.0-dev master.
I'm using IE11 64-bit (11.0.9600.17843) on Windows 7

Can you test again? Thank you

#19

Updated by Inge Khodjasteh about 6 years ago

Hi!
file uploads works again with IE 11 and Typo3 6.2.15 and 6.2.17!
Thanks a lot!

#20

Updated by Markus Klein about 6 years ago

  • Status changed from Needs Feedback to Closed

Also available in: Atom PDF