Bug #69010

"Click Enlarge" not working correctly with umlauts

Added by Wolfgang Hamster about 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Frontend
Target version:
-
Start date:
2015-08-13
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

If the filename consists an umlaut the a-href output looks like "index.php?eID=tx_cms_showpic&file=23781...."

Otherwise without an umlaut the output was: ".../fileadmin/....jpg"

Does anyone confirm?


Files

output.jpg (40.3 KB) output.jpg Wolfgang Hamster, 2015-10-08 10:55
#1

Updated by Jan Helke about 6 years ago

  • Status changed from New to Needs Feedback

Sorry, I could not confirm this. Neither with 6.2.14 nor master. Both images with and without umlaut generate the link containing the "tx_cms_showpic" parameter.

The tx_cms_showpic should be the correct link, because the images run thru some processing / rescaleing stuff.

Wild guess:

Check if something prevents the image without umlaut (with the direct reference to fileadmin) from being processed. E.g. some noScaleUp option is set and the image in question is smaller than the value for styles.content.imgtext.linkWrap.width

Could you please check into that direction. It that is not the problem, we need more information about your system.

#2

Updated by Wolfgang Hamster about 6 years ago

My output with the same file looks like...
(Typo3 6.2.14)

#3

Updated by Jan Helke about 6 years ago

Could that be related to the OS? I am using Mint Linux (there it worked) and got some negative feedback from an OSX user for a similar issue. Could you provide some informations about your environment? OS, webserver, such stuff.

#4

Updated by Riccardo De Contardi almost 6 years ago

  • Status changed from Needs Feedback to Closed

No feedback within the last 90 days => closing this issue.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF