Task #69019

Allow to mock concrete methods of abstracts classes when mocking abstract class using @getAccessibleMockForAbstractClass@.

Added by Jost Baron about 6 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2015-08-13
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
no-brainer
Sprint Focus:

Description

PHPUnit has support for this, but TYPO3 has not.

Just need this issue so Gerrit lets me push a patch.


Related issues

Is duplicate of TYPO3 Core - Feature #72062: Mocking of concrete methods in abstract classesClosed2015-12-04

Actions
#1

Updated by Gerrit Code Review about 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/42565

#2

Updated by Gerrit Code Review about 6 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/42565

#3

Updated by Daniel Goerz almost 6 years ago

  • Status changed from Under Review to Resolved

Resolved with #72062.

#4

Updated by Benni Mack about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF